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BIM system

Space Patterns
Web App

User

Space
Layout
Generator

Space model server

User

Workflow

Space model is generated

2. Upload ‘input layout.zip’

3. Choose options

4. Start space model generation

5. Visualize space model

6. Edit labels

7. Repeat 3. - 6. until the space       

model is correct

1. Create input layout (source space data)

8. Download space model

9. Visualize space model offline

10. Edit labels offline
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Software requirements

1. Install Revit

2. Install WinZip
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Install Revit

https://www.autodesk.de/education/home
Older versions of Revit are ok if 

already installed!

https://www.autodesk.de/education/home
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Revit requirements

https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/System-requirements-for-Revit-2024-products.html

https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/System-requirements-for-Revit-2024-products.html


Space Modeler User Guide – Preparing an input layout in Revit 5

Software requirements

1. Install Revit

2. Install 7-Zip

Used to set up project files and create 

‘input_layout.zip’ archives
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Download 7-Zip ( https://www.7-zip.org/download.html )

https://www.7-zip.org/download.html
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Run 7-Zip installer

Copy path to installation directory for 

later use
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Windows: Add path to 7-Zip directory to Environment Variables

Windows Start Menu
1.

2.

3.
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Windows: Add path to 7-Zip directory to Environment Variables
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Windows: Add path to 7-Zip directory to Environment Variables

Copy

1.

2.

3.

Paste
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Restart your computer
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create building elements

6. Create windows

7. Create horizontal external elements

8. Create geocoordinates

9. Generate space model
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_template_space_modeler_project.zip > WinZip > Unzip to here

Project folder

Project template .zip archive
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Open ‘input_layout_rvt’ folder
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Make a copy of ‘_template_input_layout.rvt’ (or rename it to ‘input_layout.rvt’)

Empty template for 

input layout
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Open ‘input_layout.rvt’
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‘input_layout.rvt’

Origin of project 

coordinate system

2 Levels

No elements!
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create rooms

9. Create circulation elements

10. Create horizontal external elements

11. Create furnishing elements

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Insert > Link > Link PDF
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Insert > Link > Link PDF
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Insert > Link > Link PDF
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Scale pdf

Drawing scale:

1cm:200cm

PDF image scale factor = 200
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Enable Snaps to lines in PDF

Input layout should 

not be located too 

far from project 

origin
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Pin to lock pdf
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Pin to lock pdf
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View > Visibility / Graphics

Shortcut: type VG
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Uncheck ‘Raster Images’ to hide pdf 
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Uncheck ‘Raster Images’ to hide pdf 
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Alternative: Hide in View > Elements (or Category)
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Alternative: Reveal Hidden Elements
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Alternative: Reveal Hidden Elements
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Alternative: Unhide view > Category



Space Modeler User Guide – Preparing an input layout in Revit 33

Alternative: Close Reveal Hidden Elements
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create rooms

9. Create circulation elements

10. Create horizontal external elements

11. Create furnishing elements

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Original pdf document: determine floor-to-floor height

Scale of sections in pdf:

1:500

1cm = 500cm = 5m
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Set elevation of Level 2

Select Level 2 

plane1.

2.

3.
3.
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create rooms

9. Create circulation elements

10. Create horizontal external elements

11. Create furnishing elements

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Determine internal and external spaces

Internal spaces

• Fully or partially separated by building enclosure from exterior

External spaces

• Model a building’s immediate surroundings

• Required for spatial evaluation, e.g., of ‘Natural lighting’ or ‘Orientation zones’ views

External space geometries must be created in the input layout in Revit!
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Determine internal and external spaces

V

"

ca. 4-5m

ca. 4-5m

External air space
(street)

Adjacent buildings 
are not modeled

Stair/loggia modeled 
as external air space

External air space
(courtyard)

External air space
(street)

External air space
(courtyard)

Entrance and living 
room modeled as 
single space

Elevator modeled as 
internal space
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Determine internal and external spaces

V

"

ca. 4-5m

ca. 4-5m

External air space
(street)

Adjacent buildings 
are not modeled

Stair/loggia modeled 
as external air space

External air space
(courtyard)

External air space
(street)

External air space
(courtyard)

Entrance and living 
room modeled as 
single space

Elevator modeled as 
internal spaceSee User Guide ‘Space modeling workflow’ for 

additional examples on how to determine 
internal and external spaces
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create rooms

9. Create circulation elements

10. Create horizontal external elements

11. Create furnishing elements

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Measure wall thickness

Measure tool
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Project Browser > Walls > Basic Walls > Duplicate an existing wall type

Rename new Type
e.g. ‘Generic – 360mm’

1.

2.

3.

Similarly duplicate 
existing door and 
window types
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Type properties…
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Type properties > Structure > Edit…

Family: ‘Basic Wall’
Type: ‘Generic – 360mm’
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Set layer thickness

Wall has single layer
Enter layer thickness
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Create Instance

Alternatives:
• Drag and drop
• WA shortcut
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Constraints > Location Line > Finish Face Exterior

Change orientation 
later, if necessary
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Draw wall segment
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Set wall orientation, if necessary
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Set wall orientation, if necessary
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Check if all walls are modeled

Free-standing wall
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Check correct wall elevations and heights
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create rooms

9. Create circulation elements

10. Create horizontal external elements

11. Create furnishing elements

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Select a wall > Override Graphics in View > By Category…

Set wall display for easy 
door editing
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Open the Visibility Graphics dialog…
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Set ‘Transparency’ value and ‘Lines’ color
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Set ‘Transparency’ value and ‘Lines’ color
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Measure door width
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Original pdf document: measure door height
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Type Properties > Set ‘Height’ and ‘Width’
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Create Instance
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Change orientation, if necessary
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Change orientation, if necessary
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Openings

Issue

• Accessible openings are not interpreted as 

separating 2 rooms by Revit’s space 
generation method

Solution

• Model openings as doors

• Label doors as openings (see User Guide 

‘Labeling a space model’)

Opening
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create rooms

9. Create circulation elements

10. Create horizontal external elements

11. Create furnishing elements

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Type Properties > Set ‘Height’, ‘Default Sill Height’, and ‘Width’ values
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Create Instance
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Create Instance
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Check correct window elevations and heights
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create circulation elements

9. Create horizontal external elements

10. Create furnishing elements

11. Create rooms

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Measure stair width
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Architecture > Stair
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Set ‘Location Line’, ‘Offset’, ‘Actual Run Width’ values
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Set ‘Base Level’ and ‘Top Level’ values

Finish Create Stair mode

Base Level: Level 1
Top Level: Level 2

1.

2.
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Check if stair starts at Level 1 and ends at Level 2
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create circulation elements

9. Create horizontal external elements

10. Create furnishing elements

11. Create rooms

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Architecture > Floor
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Draw boundary lines
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Check level
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Finish edit mode

Finish Create Floor mode
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Floor element should be colored if its creation is successful
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Check correct elevations of horizontal external elements
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create circulation elements

9. Create horizontal external elements

10. Create furnishing elements

11. Create rooms

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Measure cabinet dimensions
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Set desk type property values
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Create Instance

Basin needs wall face 
host
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Online resources for generic and manufacturer BIM objects:
e.g. National BIM library (UK, https://www.nationalbimlibrary.com/ )

Use Revit families from 
online resources, if 
necessary

https://www.nationalbimlibrary.com/
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Online resources for generic and manufacturer BIM objects:
e.g. National BIM library (UK, https://www.nationalbimlibrary.com/ )

https://www.nationalbimlibrary.com/
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.rfa: format for Revit family definitions
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.rfa: format for Revit family definitions
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Insert > Load Family
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Insert > Load Family
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Insert > Load Family

Basin family is loaded in the 
‘Plumbing Fixtures’ category
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Type data
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Create Instance
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Check if all furnishing elements have been placed correctly
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Check if all furnishing elements have been placed correctly
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create circulation elements

9. Create horizontal external elements

10. Create furnishing elements

11. Create rooms

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Architecture > Room & Area > Area and Volume Computations
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Select ‘Areas only (faster)’ and ‘At wall center’ options

Space modeler requirement:
• Geometries of adjacent 

rooms must touch!
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Architecture > Room & Area > Room
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Place Rooms Automatically
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Place Rooms Automatically
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Rooms are tagged
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Define section to check correct room elevations and heights

Sections symbols visible in 
Level 1 view
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View > Section
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Set section parameter values

Change 
direction, if 
necessary
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New section is added in Project Browser > Sections



Space Modeler User Guide – Preparing an input layout in Revit 111

Project Browser > Sections > Section 1
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Alternative: select Section symbol to open section view

Double 
mouse-click
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View > Visibility / Graphics > Rooms

Check ‘Interior Fill’ and ‘Reference’
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Set room constraints

Upper Limit = Level 2
Limit Offset = 0.0
Base Offset = 0.0
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Project Browser > Schedules/Quantities > Room Schedule

• Check if areas make sense
• They may be too large or too 

small when the project’s scale 
is incorrect
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Check if all rooms are tagged



Space Modeler User Guide – Preparing an input layout in Revit 118

View > Visibility / Graphics > Rooms

Check ‘Interior Fill’ and ‘Reference’
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Check if room geometries are generated 
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Check if room geometries are generated 

Missing room



Space Modeler User Guide – Preparing an input layout in Revit 121

Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create circulation elements

9. Create horizontal external elements

10. Create furnishing elements

11. Create rooms

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model



Space Modeler User Guide – Preparing an input layout in Revit 122

Create geocoordinates

• Determine geocoordinates in Open Street Map

• Edit geocoordinates in Revit
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Determine geocoordinates in Open Street Map

• Open Street Map (OSM): 

• Determine geocoordinates based on building outlines (‘features’)

• Google Maps (GM): 

• Determine geocoordinates based on satellite images

• Discrepancies between OSM and GM coordinates

• Model visualizations on GM typically do not match with maps or 

satellite images

• OSM coordinates are used because they are easier to validate

• 2 geocoordinates are required

• p1: locate the input layout in geo coordinate system

• p2: orientation (direction) of the input layout in geocoordinate 

system

• Edit geocoordinates in Revit

p1

p2
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Determine geocoordinates p1 and p2

p1

p2

p1’

p2’

p1 → p1’:

Exact match between geocoordinates and local 
(input layout) coordinates required

p2’

Geo coordinate system (Open Street Map)

Local (input layout) coordinate system (Revit)

p2 → p2’:

p2’ must lie on line that starts at p1’ and 
whose direction corresponds to that of 
line (p1, p2)

No exact match required
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Determine geocoordinates p1 and p2

p1

p2

p1’

p2’
p2’

Geo coordinate system (OSM)

Local (input layout) coordinate system (Revit)

This option for p2’ is easily located in 
the input layout

Preferred option for p2’

This option for p2’ corresponds to p2 
but is not easily located in the input 
layout

Less preferred option for p2’
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Determine geocoordinates p1 and p2

p2

p1

p2’

p1’

Geo coordinate system (OSM)

Local (input layout) coordinate system (Revit)

Alternative selection of p1 and 
p2

p1’ and p2’ are easily located in 
the input layout

p1’ does not need to be at the 
origin of the local coordinate 
system!
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Text editor: set up file to paste geocoordinates
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Open Street Map (www.openstreetmap.org )
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Enter street name
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Query features
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Query features
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Select feature
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p1: select feature node (trial and error)
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p1: copy geocoordinate of node

p1: locate the input layout in geo coordinate system 
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p1: paste to text editor

p1: locate the input layout in geo coordinate system 
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p2: select feature node (trial and error)
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p2: copy geocoordinate of node

p2: orientation (direction) of the input 
layout in geo coordinate system 
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p2: Paste to text editor

p2: orientation (direction) of the input 
layout in geo coordinate system 
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Create geocoordinates

• Determine geocoordinates in Open Street Map

• Edit geocoordinates in Revit
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Annotate > Text
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Text editor: copy p1
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Upper left corner of text element should coincide with chosen location
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Text editor: copy p2
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Upper left corner of text element should coincide with chosen location
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Check if p1 and p2 are correctly positioned
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View > Visibility / Graphics > Text Notes

• Check ‘Text Notes’
• Otherwise they are not exported
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create circulation elements

9. Create horizontal external elements

10. Create furnishing elements

11. Create rooms

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Export input layout

• Export to Industry Foundation Classes (IFC) format (.ifc)

• Export to Autocad drawing format (.dwg)

‘input_layout.ifc’ is processed by 
Space Modeler
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File > Export > IFC



Space Modeler User Guide – Preparing an input layout in Revit 150

Select ‘space_modeler_ifc_export_setup’ from ‘Current selected setup’
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Export



Space Modeler User Guide – Preparing an input layout in Revit 152

Export runs in the background

• Progress messages
• Export is done when there are 

no messages
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Check ‘input_layout.ifc’ in ‘input_layout_rvt’ folder

‘input_layout.ifc’ is saved to the 
‘input_layout_rvt’ folder
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Troubleshooting: ‘space_modeler_ifc_export_setup’ is missing
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Troubleshooting: Modify setup > Import setup…
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Open ‘space_modeler_ifc_export_setup.json’ file in ‘input_layout_rvt’ folder
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Select ‘space_modeler_ifc_export_setup’ option



Space Modeler User Guide – Preparing an input layout in Revit 158

Export
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Export input layout

• Export to Industry Foundation Classes (IFC) format (.ifc)

• Export to Autocad drawing format (.dwg)

Geocoordinates are saved here 
because they are not exported to 
IFC
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Project Browser > Floor Plans > Level 1



Space Modeler User Guide – Preparing an input layout in Revit 161

File > Export > CAD Formats > DWG
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Select ‘space_modeler_dwg_export_setup’ (if available)
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Alternative (if ‘space_modeler_dwg_export_setup’ unavailable): 
<in-session export setup>  … 
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Alternative (if ‘space_modeler_dwg_export_setup’ unavailable): 
Units & Coordinates > One DWG unit is: > Meter
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Next…
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Save as ‘input_layout_geo.dwg’ file to ‘input_layout_dwg’ folder

‘input_layout_dwg’ folder

‘input_layout_geo.dwg’ file
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Check ‘input_layout_geo.dwg’ in ‘input_layout_dwg’ folder



Space Modeler User Guide – Preparing an input layout in Revit 168

Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create circulation elements

9. Create horizontal external elements

10. Create furnishing elements

11. Create rooms

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
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Run ‘_input_layout_zip.bat’ script in project folder

Double 
mouse-click



Space Modeler User Guide – Preparing an input layout in Revit 170

Check if ‘input_layout.zip’ archive has been created

Only relevant for offline edits. 
This message may be ignored 
in the first iteration.
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Check if ‘input_layout.zip’ archive has been created

This file will be uploaded to the 
SpacePatterns web app
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Troubleshooting: Missing ‘input_layout.ifc’ (or ‘input_layout.dwg’)
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Troubleshooting: Check ‘input_layout.ifc’ file in ‘input_layout_rvt’ folder

‘input_layout_rvt’ folder
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Steps

1. Set up project

2. Import pdf of original floor plan

3. Set floor-to-floor height

4. Determine internal and external spaces

5. Create walls

6. Create doors and openings

7. Create windows

8. Create circulation elements

9. Create horizontal external elements

10. Create furnishing elements

11. Create rooms

12. Create geocoordinates

13. Export input layout

14. Create .zip archive

15. Generate space model
See User Guide ‘Generating a space model’


